Extruder does not purge at all

Just installed everything and adjusted gcode, all that went fine, but when we print the Purge Fast gcode to extrude the material, nothing happens. The machine seems to vibrate a bit, but nothing is moving and the file seems to take forever, it already says it is over an hour and it is not moving.

Can you tell me more about the material you are trying to print? There are some materials that simply don’t have the right characteristics for extrusion.

Hi Charles,
actually we are using it without any material.
The point is, that the lift is not running. The motor seems to work but there is no action on the threaded rod.

Hi Fikret,

Do you have the allen key inserted? If the allen key is not inserted, the lead screw will not move at all. (The lead screw itself will not rotate…the gearbox in our product pushes the lead screw up/down – but only if the allen key is inserted.)


Hi Charles,
yes, the key is inserted but nothing happens.
Is there any other setting we have to note?

Can you send me a photo of how you have the Discov3ry set up? The movement rate of the lead screw is about 10 mL per hour (so the full 60 cc is about 6 hours of printing). It will be really slow if you are trying to watch it. But you can place a piece of tape on one of the four guide screws, perhaps 1 cm above the syringe grip (white 3d printed part where the allen key is inserted), then double check the distance after running it for 20 minutes or so.

I have also a similar case. I am using nutella as a material. Does it really purge very slow even if i set it to purge fast? Is my set up in my photo attached correct? Thank you!

For some reason, I don’t see your photo. The Discov3ry is designed for power (torque) over speed, though, so this can be confusing when people are used to the fast speed of filament loading and printing.

It typically will take is about 6 hours to print the full volume of a 60 cc syringe, so that is 10 cc/hour. As the material moves through the tubing, it will advance at a rate of about 1-2 cm/minute.

If you still have questions, please let me know.

Hey Charles,
I’m having a similar issue. The motors are working and the gear is turning as well. However the threaded rod does not move up. I put a mark on it to verify. The allen key is inserted.

Hi arayb1,

What material are you using?

Can you also tell me your gcode settings for the M92 command as well as the flow% (or flow rate) you have set in your slicer? (What slicer software are you using?)


I’m testing it out without any material as of now just to see how it operates. I’m using M92 E2000. I’m using Cura right now but I’m not sure where to find flow%? I’m only adjusting print speed.\


Usually, we recommend using a value for “M92 Exxxx” that is about 10x the value used for filament. So look at a gcode file you have used for filament and try that. We typically use “M92 E2600” for the Ultimaker 2+.

For the flow% in Cura, it is located in the “Materials” section (screenshot attached).

Try increasing this flow% value if needed.

Please note, the Discov3ry is designed for power over speed, so it will move very slow. Typically, it will take 1 hour to plunge 10 cc.

Thanks for replying. I tried changing the Exxx value to 2600, 12000, 36000 and also the flow. The lead screw still doesn’t move up even after waiting a long time. Maybe I’m missing something else here?

I think its working now! I changed the settings yet again and its going up real slow but atleast it works haha. Thanks a lot for your help Charles! :slight_smile: